#17 ✓resolved
Josh Wand

documentation/tutorials out of sync

Reported by Josh Wand | February 11th, 2009 @ 02:55 AM

There are several places where scRUBYt docs live, and almost none of them have the same syntax, etc.:

http://scrubyt.rubyforge.org/ (version not clear, dates from 2006) http://wiki.scrubyt.org/index.ph... (v0.3) http://www.rubyrailways.com/data... (some syntax, e.g. for logging, is no longer current) http://rubypond.com/articles/200... (recent-- too recent)

Since each of these is maintained by a project contributor, it seems like it would be helpful to point out what is deprecated, and point to some authoritative, up-to-date source for the API.

(It doesn't help that there are 3 branches in the wild-- rubyforge gem, github gem, github skimr branch)

Comments and changes to this ticket

  • Peter Szinek

    Peter Szinek February 11th, 2009 @ 08:19 AM

    • State changed from “new” to “resolved”

    Josh, you are absolutely right. To clear up the confusion a bit:

    As for the branches:

    • rubyforge gem is the latest official stable version
    • github gem is the same, plus a few additional fixes - it's released to rubyforge officially when it makes sense (i.e. not after 2 small fixes). Basically I would recommend to use thi version.
    • skimr - this is a bottom up rewrite branch. Mucn more stable, well documented (what you can see @ rubypond is about what you can do with it) but has a lot less features than the original branch.

    So here's the deal: we are putting (almost) all our efforts into the skimr branch - once all (or most of) the features will be ported over from the original branch, that branch will be abandoned for good (i.e. the 'skimr' branch will replace it).

    This also means that we are not doing too much about the current branch, except fixing bugs - there is just no time to keep up with everything... the new version will have proper, maintained, up to date documentation, but the current one, unless someone volunteers, won't...

  • Josh Wand

    Josh Wand February 11th, 2009 @ 02:31 PM

    Might I suggest you at least put a small update notice on all those various sources indicating their deprecated status?

    Consider the POV of someone doing a google search for docs, like I did.

    Thanks, --Josh

  • Peter Szinek

    Peter Szinek February 19th, 2009 @ 12:37 AM

    Sure, that makes sense, will do... only if I could remember what all those places are :-)

  • NoelIngrid32

    NoelIngrid32 April 29th, 2010 @ 03:18 AM

    People in all countries get the lowest-rate-loans.com in different banks, just because that's comfortable and fast.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

A simple to learn and use, yet powerful web scraping toolkit written in Ruby.

People watching this ticket

Pages